using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,3}[.,]\d+[, -]+\d{1,3}[.,]\d+";
string input = @"38.622446, -76.941988
53.545265,-113.486355
17.41586,78.48162
58,4272 15,6001
1234.4567.8910
1234-4567-8910
1234 4567 8910
1234 4567 8910.2 players ready
Cobalion-1234 4567 8910-3players waiting";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}