import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,3}[.,]\\d+[, -]+\\d{1,3}[.,]\\d+";
final String string = "38.622446, -76.941988\n"
+ "53.545265,-113.486355\n"
+ "17.41586,78.48162\n"
+ "58,4272 15,6001\n\n"
+ "1234.4567.8910\n"
+ "1234-4567-8910\n"
+ "1234 4567 8910\n"
+ "1234 4567 8910.2 players ready\n"
+ "Cobalion-1234 4567 8910-3players waiting";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}