import Foundation
let pattern = #"\d{1,3}[.,]\d+[, -]+\d{1,3}[.,]\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
38.622446, -76.941988
53.545265,-113.486355
17.41586,78.48162
58,4272 15,6001
1234.4567.8910
1234-4567-8910
1234 4567 8910
1234 4567 8910.2 players ready
Cobalion-1234 4567 8910-3players waiting
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)