using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*([abc]).*\1)[abc]{3}$";
string input = @"abc
bac
cba
acb
cab
a
ab
ba
bc
ca
c
aba
acc
abb
cca
aab
abcd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}