re = /^(?!.*([abc]).*\1)[abc]{3}$/m
str = 'abc
bac
cba
acb
cab
a
ab
ba
bc
ca
c
aba
acc
abb
cca
aab
abcd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end