$re = '/^(?!.*([abc]).*\1)[abc]{3}$/m';
$str = 'abc
bac
cba
acb
cab
a
ab
ba
bc
ca
c
aba
acc
abb
cca
aab
abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);