import re
regex = re.compile(r"^(?!.*([abc]).*\1)[abc]{3}$", flags=re.MULTILINE)
test_str = ("abc\n"
"bac\n"
"cba\n"
"acb\n"
"cab\n\n"
"a\n"
"ab\n"
"ba\n"
"bc\n"
"ca\n"
"c\n"
"aba\n"
"acc\n"
"abb\n"
"cca\n"
"aab\n"
"abcd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")