import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*([abc]).*\\1)[abc]{3}$";
final String string = "abc\n"
+ "bac\n"
+ "cba\n"
+ "acb\n"
+ "cab\n\n"
+ "a\n"
+ "ab\n"
+ "ba\n"
+ "bc\n"
+ "ca\n"
+ "c\n"
+ "aba\n"
+ "acc\n"
+ "abb\n"
+ "cca\n"
+ "aab\n"
+ "abcd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}