using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\b401\b)(?=.*?\be?30(?:th|st)?\b).*";
string input = @"401 300th st
40120 30 street
30 401 plz
401 30th st
401 e gibbsborro rd, 305
401 e 30th street, shelter
401 east 30st
401 e30th street, 3
77-02 30th ave, 3rd fl
401 e30 st.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}