use strict;
my $str = '401 300th st
40120 30 street
30 401 plz
401 30th st
401 e gibbsborro rd, 305
401 e 30th street, shelter
401 east 30st
401 e30th street, 3
77-02 30th ave, 3rd fl
401 e30 st.
';
my $regex = qr/^(?=.*\b401\b)(?=.*?\be?30(?:th|st)?\b).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}