import Foundation
let pattern = #"^(?=.*\b401\b)(?=.*?\be?30(?:th|st)?\b).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
401 300th st
40120 30 street
30 401 plz
401 30th st
401 e gibbsborro rd, 305
401 e 30th street, shelter
401 east 30st
401 e30th street, 3
77-02 30th ave, 3rd fl
401 e30 st.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)