using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/lnkd\.in\/[\w]{6,8}#[^>]+";
string input = @"https://lnkd.in/eGdcPMUF#cl!1LumKruvpcw609V!d=11156_pd!kautLpk5gd!c=79793!YMjC54EQwFalv!l=367!acz0TyRlP4MnyZTvzmdcv9MKhFjY1YqiWitr1kLGkEMr!o=1322!V9WPiRhXeNx1xkrjDgeEIjboANnHxdLtp1DV90x3!v=1020463!mTwi7jAgR5Of5R!m=2210!nHGsRgDzd0yakbWR64r5ec8Bad3HfCuAvjDof73wH";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}