re = /https?:\/\/lnkd\.in\/[\w]{6,8}#[^>]+/m
str = 'https://lnkd.in/eGdcPMUF#cl!1LumKruvpcw609V!d=11156_pd!kautLpk5gd!c=79793!YMjC54EQwFalv!l=367!acz0TyRlP4MnyZTvzmdcv9MKhFjY1YqiWitr1kLGkEMr!o=1322!V9WPiRhXeNx1xkrjDgeEIjboANnHxdLtp1DV90x3!v=1020463!mTwi7jAgR5Of5R!m=2210!nHGsRgDzd0yakbWR64r5ec8Bad3HfCuAvjDof73wH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end