// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/\/lnkd\.in\/[\w]{6,8}#[^>]+").unwrap();
let string = "https://lnkd.in/eGdcPMUF#cl!1LumKruvpcw609V!d=11156_pd!kautLpk5gd!c=79793!YMjC54EQwFalv!l=367!acz0TyRlP4MnyZTvzmdcv9MKhFjY1YqiWitr1kLGkEMr!o=1322!V9WPiRhXeNx1xkrjDgeEIjboANnHxdLtp1DV90x3!v=1020463!mTwi7jAgR5Of5R!m=2210!nHGsRgDzd0yakbWR64r5ec8Bad3HfCuAvjDof73wH";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}