# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?:\/\/lnkd\.in\/[\w]{6,8}#[^>]+"
test_str = "https://lnkd.in/eGdcPMUF#cl!1LumKruvpcw609V!d=11156_pd!kautLpk5gd!c=79793!YMjC54EQwFalv!l=367!acz0TyRlP4MnyZTvzmdcv9MKhFjY1YqiWitr1kLGkEMr!o=1322!V9WPiRhXeNx1xkrjDgeEIjboANnHxdLtp1DV90x3!v=1020463!mTwi7jAgR5Of5R!m=2210!nHGsRgDzd0yakbWR64r5ec8Bad3HfCuAvjDof73wH"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.