import Foundation
let pattern = ##"https?:\/\/lnkd\.in\/[\w]{6,8}#[^>]+"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"https://lnkd.in/eGdcPMUF#cl!1LumKruvpcw609V!d=11156_pd!kautLpk5gd!c=79793!YMjC54EQwFalv!l=367!acz0TyRlP4MnyZTvzmdcv9MKhFjY1YqiWitr1kLGkEMr!o=1322!V9WPiRhXeNx1xkrjDgeEIjboANnHxdLtp1DV90x3!v=1020463!mTwi7jAgR5Of5R!m=2210!nHGsRgDzd0yakbWR64r5ec8Bad3HfCuAvjDof73wH"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)