using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s\d+";
string input = @" 26, 28-30, October 1-8, 10, 11, 15-20, 24, November 25, 28-30";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}