re = /\w+\s\d+/
str = ' 26, 28-30, October 1-8, 10, 11, 15-20, 24, November 25, 28-30'
# Print the match result
str.match(re) do |match|
puts match.to_s
end