$re = '/\w+\s\d+/';
$str = ' 26, 28-30, October 1-8, 10, 11, 15-20, 24, November 25, 28-30';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);