import Foundation
let pattern = #"\w+\s\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" 26, 28-30, October 1-8, 10, 11, 15-20, 24, November 25, 28-30"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}