const regex = /\w+\s\d+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+\\s\\d+', '')
const str = ` 26, 28-30, October 1-8, 10, 11, 15-20, 24, November 25, 28-30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}