using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+)\s+:\s+(\d+\.?\d*)([a-z]+)";
string input = @"Height : 435mm Width : 700mm Depth : 50mm Weight : 7.60Kg";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}