const regex = /([a-z]+)\s+:\s+(\d+\.?\d*)([a-z]+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z]+)\\s+:\\s+(\\d+\\.?\\d*)([a-z]+)', 'gi')
const str = `Height : 435mm Width : 700mm Depth : 50mm Weight : 7.60Kg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}