// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([a-z]+)\s+:\s+(\d+\.?\d*)([a-z]+)").unwrap();
let string = "Height : 435mm Width : 700mm Depth : 50mm Weight : 7.60Kg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}