$re = '/([a-z]+)\s+:\s+(\d+\.?\d*)([a-z]+)/i';
$str = 'Height : 435mm Width : 700mm Depth : 50mm Weight : 7.60Kg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);