package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([a-z]+)\s+:\s+(\d+\.?\d*)([a-z]+)`)
var str = `Height : 435mm Width : 700mm Depth : 50mm Weight : 7.60Kg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}