#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)\1+"
Local $sString = "The quick brown fox jumps over the lazy dogThe quick brown fox jumps over the lazy dog" & @CRLF & _
"ApplesApplesApples" & @CRLF & _
"IBM AT Computer" & @CRLF & _
"Lamp ShadeLamp Shade" & @CRLF & _
"OrangesOranges" & @CRLF & _
"I am a Potato" & @CRLF & _
"i am i am i am a potato"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)