import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*)\\1+";
final String string = "The quick brown fox jumps over the lazy dogThe quick brown fox jumps over the lazy dog\n"
+ "ApplesApplesApples\n"
+ "IBM AT Computer\n"
+ "Lamp ShadeLamp Shade\n"
+ "OrangesOranges\n"
+ "I am a Potato\n"
+ "i am i am i am a potato";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}