import re
regex = re.compile(r"^(.*)\1+", flags=re.MULTILINE)
test_str = ("The quick brown fox jumps over the lazy dogThe quick brown fox jumps over the lazy dog\n"
"ApplesApplesApples\n"
"IBM AT Computer\n"
"Lamp ShadeLamp Shade\n"
"OrangesOranges\n"
"I am a Potato\n"
"i am i am i am a potato")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)