re = /^(.*)\1+/m
str = 'The quick brown fox jumps over the lazy dogThe quick brown fox jumps over the lazy dog
ApplesApplesApples
IBM AT Computer
Lamp ShadeLamp Shade
OrangesOranges
I am a Potato
i am i am i am a potato'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result