using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/(?P<params>[^/#].*(?:[^\n.].{2}$|.[^\nj].$|.{2}[^\ns]$))$";
string input = @"/#something
/something
/something.js
/something.ja
/somethingjs
/somethingjs.
/somethin.gjs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}