$re = '`/(?P<params>[^/#].*(?:[^\n.].{2}$|.[^\nj].$|.{2}[^\ns]$))$`m';
$str = '/#something
/something
/something.js
/something.ja
/somethingjs
/somethingjs.
/somethin.gjs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);