import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/(?P<params>[^/#].*(?:[^\\n.].{2}$|.[^\\nj].$|.{2}[^\\ns]$))$";
final String string = "/#something\n"
+ "/something\n"
+ "/something.js\n"
+ "/something.ja\n"
+ "/somethingjs\n"
+ "/somethingjs.\n"
+ "/somethin.gjs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}