package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/(?P<params>[^/#].*(?:[^\n.].{2}$|.[^\nj].$|.{2}[^\ns]$))$`)
var str = `/#something
/something
/something.js
/something.ja
/somethingjs
/somethingjs.
/somethin.gjs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}