#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((foo|bar) is (baz|hello|what)|hello world)$"
Local $sString = "hello world" & @CRLF & _
"foo is baz" & @CRLF & _
"bar is what" & @CRLF & _
"foo is hello" & @CRLF & _
"foo is what" & @CRLF & _
"bar is baz" & @CRLF & _
"bar is hello"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")