using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((foo|bar) is (baz|hello|what)|hello world)$";
string input = @"hello world
foo is baz
bar is what
foo is hello
foo is what
bar is baz
bar is hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}