$re = '/^((foo|bar) is (baz|hello|what)|hello world)$/m';
$str = 'hello world
foo is baz
bar is what
foo is hello
foo is what
bar is baz
bar is hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);