// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((foo|bar) is (baz|hello|what)|hello world)$").unwrap();
let string = "hello world
foo is baz
bar is what
foo is hello
foo is what
bar is baz
bar is hello";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}