import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((foo|bar) is (baz|hello|what)|hello world)$";
final String string = "hello world\n"
+ "foo is baz\n"
+ "bar is what\n"
+ "foo is hello\n"
+ "foo is what\n"
+ "bar is baz\n"
+ "bar is hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}