using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Id"":(\d+)}.*";
string substitution = @"\1";
string input = @"{""left"":""foo"",""right"":""no""},""answer"":""left"",""Id"":258}""
abb <- ""{""left"":""foo"",""up"":""no""},""answer"":""updownupdwon"",""Id"":258}""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}