// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".*Id":(\d+)}.*"#).unwrap();
let string = "{\"left\":\"foo\",\"right\":\"no\"},\"answer\":\"left\",\"Id\":258}\"
abb <- \"{\"left\":\"foo\",\"up\":\"no\"},\"answer\":\"updownupdwon\",\"Id\":258}\"";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}