$re = '/.*Id":(\d+)}.*/';
$str = '{"left":"foo","right":"no"},"answer":"left","Id":258}"
abb <- "{"left":"foo","up":"no"},"answer":"updownupdwon","Id":258}"';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;