import re
regex = re.compile(r".*Id\":(\d+)}.*")
test_str = ("{\"left\":\"foo\",\"right\":\"no\"},\"answer\":\"left\",\"Id\":258}\"\n"
"abb <- \"{\"left\":\"foo\",\"up\":\"no\"},\"answer\":\"updownupdwon\",\"Id\":258}\"")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)