re = /.*Id":(\d+)}.*/
str = '{"left":"foo","right":"no"},"answer":"left","Id":258}"
abb <- "{"left":"foo","up":"no"},"answer":"updownupdwon","Id":258}"'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result