using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?<protocol>https?|ssh|git|ftps?):\/\/)?((?<user>[^\/@]+)@)?(?<hostname>[^\/:]+)[\/:](?<pathHead>[^\/:]+)\/(?<pathTail>(.+)(.git)?\/?)$";
string input = @"git://github.com/org/path/my-repo.git
git@github.com:org/path/my-repo.git
https://github.com/org/path/my-repo.git
ssh://git@github.com/org/path/my-repo.git/
ftps://github.com/org/path/my-repo.git
http://user@host.com/org/path/gigi
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}