$re = '/^((?<protocol>https?|ssh|git|ftps?):\/\/)?((?<user>[^\/@]+)@)?(?<hostname>[^\/:]+)[\/:](?<pathHead>[^\/:]+)\/(?<pathTail>(.+)(.git)?\/?)$/m';
$str = 'git://github.com/org/path/my-repo.git
git@github.com:org/path/my-repo.git
https://github.com/org/path/my-repo.git
ssh://git@github.com/org/path/my-repo.git/
ftps://github.com/org/path/my-repo.git
http://user@host.com/org/path/gigi
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);