use strict;
my $str = 'git://github.com/org/path/my-repo.git
git@github.com:org/path/my-repo.git
https://github.com/org/path/my-repo.git
ssh://git@github.com/org/path/my-repo.git/
ftps://github.com/org/path/my-repo.git
http://user@host.com/org/path/gigi
';
my $regex = qr/^((?<protocol>https?|ssh|git|ftps?):\/\/)?((?<user>[^\/@]+)@)?(?<hostname>[^\/:]+)[\/:](?<pathHead>[^\/:]+)\/(?<pathTail>(.+)(.git)?\/?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}