// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?<protocol>https?|ssh|git|ftps?):\/\/)?((?<user>[^\/@]+)@)?(?<hostname>[^\/:]+)[\/:](?<pathHead>[^\/:]+)\/(?<pathTail>(.+)(.git)?\/?)$").unwrap();
let string = "git://github.com/org/path/my-repo.git
git@github.com:org/path/my-repo.git
https://github.com/org/path/my-repo.git
ssh://git@github.com/org/path/my-repo.git/
ftps://github.com/org/path/my-repo.git
http://user@host.com/org/path/gigi
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}