import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?<protocol>https?|ssh|git|ftps?):\\/\\/)?((?<user>[^\\/@]+)@)?(?<hostname>[^\\/:]+)[\\/:](?<pathHead>[^\\/:]+)\\/(?<pathTail>(.+)(.git)?\\/?)$";
final String string = "git://github.com/org/path/my-repo.git\n"
+ "git@github.com:org/path/my-repo.git\n"
+ "https://github.com/org/path/my-repo.git\n"
+ "ssh://git@github.com/org/path/my-repo.git/\n"
+ "ftps://github.com/org/path/my-repo.git\n"
+ "http://user@host.com/org/path/gigi\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}