using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+Mbps/(\d+)M";
string input = @"My ADSL 14Mbps/2M speed
My ADSL 2M(200) Volume 14Mbps/2M speed threshold 0M";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}